OLED stopped working overnight, everything seems to check out and work otherwise

Well I’m stumped at the moment. After printing and installing the enclosure yesterday, which you can see my mods I shared here , I had it plugged in and all was working just fine, I slid the cover over the LCD and went to bed. This morning I wake up, slide the cover and…no display! I checked the power supply and it was good, the orange LED on the CO2 sensor was blinking as was the WEMOS blue LED so everything was getting power. I moved the device to my PC where I watched it all working in serial monitor. Data output is as expected. The whole assembly has been working just fine for days. Any thoughts on why the OLED would just up and die?

09:52:57.732 -> ⸮⸮CO2 Successfully Initialized. Heating up for 10s
09:53:08.582 -> *WM: [1] AutoConnect 
09:53:08.582 -> *WM: [2] Connecting as wifi client... 
09:53:08.582 -> *WM: [3] STA static IP:
09:53:08.629 -> *WM: [2] setSTAConfig static ip not set, skipping 
09:53:08.676 -> *WM: [1] Connecting to SAVED AP: 
09:53:08.722 -> *WM: [3] Using Password: 
09:53:08.768 -> *WM: [3] WiFi station enable 
09:53:08.815 -> *WM: [3] enableSTA PERSISTENT ON 
09:53:08.815 -> *WM: [1] connectTimeout not set, ESP waitForConnectResult... 
09:53:08.907 -> *WM: [2] Connection result: WL_CONNECTED
09:53:08.953 -> *WM: [3] lastconxresult: WL_CONNECTED
09:53:09.000 -> *WM: [1] AutoConnect: SUCCESS 
09:53:09.045 -> *WM: [1] STA IP Address: 192.168.20.152
09:53:09.045 -> *WM: [3] unloading 
09:53:20.101 -> {"wifi":-30,"pm02":0,"rco2":853,"atmp":23.90,"rhum":43}
09:53:20.146 -> http://hw.airgradient.com/sensors/airgradient:xxxxx/measures
09:53:20.703 -> 200
09:53:20.703 -> {"timestamp":1650981200000,"date":"09:53:20","pm02":0,"pm02_clr":"green","pm02_lbl":"Good","pm02_idx":1,"pm02_raw":1,"pi02":0,"pi02_min":0,"pi02_max":0,"pi02_clr":"green","pi02_lbl":"Good","pi02_idx":1,"atmp":23.9,"rhum":43,"rco2":853,"rco2_clr":"yellow","rco2_lbl":"Good","rco2_idx":2,"wifi":-30,"heatindex":23.9,"heatindex_clr":"green","heatindex_lbl":"Good","heatindex_idx":1,"heat_index_fahrenheit":75,"heat_index_celsius":23.9,"atmp_fahrenheit":75,"c19_score":3,"c19_score_lbl":"medium"}
09:53:51.211 -> {"wifi":-28,"pm02":0,"rco2":1836,"atmp":23.90,"rhum":38}
09:53:51.257 -> http://hw.airgradient.com/sensors/airgradient:xxxxxx/measures
09:53:51.760 -> 200
09:53:51.760 -> {"timestamp":1650981231000,"date":"09:53:51","pm02":0,"pm02_clr":"green","pm02_lbl":"Good","pm02_idx":1,"pm02_raw":1,"pi02":0,"pi02_min":0,"pi02_max":0,"pi02_clr":"green","pi02_lbl":"Good","pi02_idx":1,"atmp":23.9,"rhum":38,"rco2":1836,"rco2_clr":"red","rco2_lbl":"Poor","rco2_idx":4,"wifi":-28,"heatindex":23.9,"heatindex_clr":"green","heatindex_lbl":"Good","heatindex_idx":1,"heat_index_fahrenheit":75,"heat_index_celsius":23.9,"atmp_fahrenheit":75,"c19_score":6,"c19_score_lbl":"medium"}

Ok, I finally got a chance to do some more testing. I grabbed a second WEMOS D1 I’ve got, hooked it up to the OLED with basic ssd1306 example…nothing. I tried another OLED I have, 128x32, and it works fine with the same example code and test WEMOS D1. Tried the same setup with another 128x64 OLED…also works just fine. Uploaded the AirGradient code I had previously used in the assembled kit, works fine, albeit with bad sensor values since they’re not hooked up. All three OLED have the same 0x3c address so it was a simple matter of swapping wires and no code changing required.

Anyone have any idea how or why an OLED would just up and die like that overnight??? Especially one that’s brand new from the kit.
@AirGradient ?

Cheap Chinese parts?

I’ve had them stop working, sit them on my bench for a few days, try them again and they all of a sudden work again…

That’s…super odd. Maybe I’ll let it ‘rest’ a few and try again ha.