Issues with new DYI Pro Presoldered kit

Ive also have some problems with this KIT.

After flashing the D1 Mini V4 and setting up wifi SSID and Password thru the 60 sek wifi config window, its online, but after unplugging it and connecting it to the Pro Presoldered board it doesnt connect to wifi. And the Oled - Top left does not turn on.

If i unplugg the D1 Mini from the board it connects to the Wifi again…

Not sure what to do next…

I also use ASUSwrt-Merlin frequently updated to latest firmware. In my region channels 12 & 13 are legal & therefore appear as options.
Using channel 11 & 6 resulted in longer periods of connection, but still occasional disconnections. Once it took 5 hours to reconnect by itself.
Setting to Auto has used channel 2 or 3 & has resulted in several days with no connection issue.
The display has frozen twice after ~ 3 days. Re-power & the AG-Pro re-connects very quickly.

My key learning so far is only use wifi channels in the ESP active scan range, ie channel 1-11.


I’ve tried “legacy” setting, all bandwidth options, “disable 11b” , & more all with no impact to the issue.

All 2.4G devices are IoT & connect on wifi “n” with one exception connecting via “g”

Home Assistant keeps reasonable history & I can be certain the issue is only with the ESP device.
Interference with Zigbee is a possibility. I have almost 20 active devices, mostly on zigbee channel 25 (nearest wifi channel 13) & several on another device zigbee channel 11 (far edge of wifi channel 1).

Just an FYI from an old guy stumbling through the forums… with 2.4GHz wifi, there are only 3 ‘pure’ channels - 1, 6 and 11

Any other channel simply interferes with these channels :slight_smile:

Try set your channel to one of the only (this is probably spoken about in the above link I have not clicked on!)


I have 2 units which arrived yesterday, one is fine but the other refuses to connect to wifi after I save the details to it.

It sits for about 60 seconds and then boots into offline mode, I can see the data on the screen but I can access it from the unit.

Any suggestions?

Please contact us on the support form. We will send you a replacement.

As you mention, 1,6 & 11 are recommended channels. So I am surprised the ASUS auto select has chosen channel 2 & 3.
When I turned auto off, I first tried channel 11, then 6 - both unsuccessfully. The I went back to Auto select.
So far , on channel 3, it is stable.

The replacement has just arrived but it doesn’t connect, like the originally shipped D1 the replacement does not connect to my Wi-fi, my other unit purchased and delivered at the same time works fine.

This is getting frustrating looks like it will be several more weeks before this unit will be working, is there anything else I can do to confirm what the problem is, are you still sending out defective D1’s? I thought the faulty ones had been identified and removed.

Sorry for that but we are now hand testing every single D1 Mini that we send out if it connects to the WiFi. So I have no idea why you still have this issue. Please contact us at and we can see how to help you best. Thanks

Hi Again, after playing with it for some time it may have connected to my network however after adding it to the dashboard no data is showing, I can see data on the units display.

When I added it there was no confirmation that it was added, it is greyed out on the hardware admin table and the last seen time it not updating even though I have rebooted it and it seems to connect.

The issue has been fixed. It is important to have only lower case letters in the sensor id. We will make some improvements for this server side as well.

Apologies for reviving up an older thread but it seems like my issue could be related.

I have just purchased 2 AirGradient kits, the Open Air and the PreSoldered DIY Pro. I connected to the OpenAir wifi fine, entered the details and successfully registered it on my wifi and to the Dashboard. It showed up as a live sensor on the dashboard and was working fine. ~15 minutes later it showed as Offline in the dashboard and it has not appeared online since. I have done the usual power cycle and different power pack etc. My wifi management console shows the Open Air as connected to the wifi with excellent connection strength… but it’s no longer connecting to the Dashboard.

In terms of additional diagnostics:

  • I have an Ubiquiti Unifi setup with multiple access points
  • The access points are auto-balanced, and only using channels 1, 6, or 11.
  • The Wifi has an event log showing that the OpenAir disconnected from wifi at 15:43 (about 3 minutes after its last update to the dashboard). It then reconnected at 15:44 and has remained connected ever since (except when I power cycle it) but it has not done any more updates to the dashboard.

The DIY Pro has stayed connected to the Wifi fine for the last half hour (and I’m continuing to monitor).

OK, some good news. I’ve managed to get it to connect by placing it within 1m of one of the APs. First I’ll make sure it’s stable and then I’ll try moving it outside.

Thanks for the update. Please let us know the result from your further testing.