Issues with new DYI Pro Presoldered kit

So i just got the Air Gradient DIY Pro Presoldered Kit. So far it seems to work, but i am having a issue completing the initial setup. Simply put the wifi range seems to be horrible, and no matter what i can’t seem to get it connected to my wifi.

I am in a fairly congested area so there are a few wifi networks around me that all of my devices pickup. When i am trying to setup the wifi it doesn’t see hardly any of them. For the longest time it wasn’t seeing mine which literally had a AP a few feet from the device. I tried a few different locations and for a brief moment it saw it. Then it would not connect or see it again after I selected it from the menu and put in my passphrase. Is there a issue with the Wifi on these devices.

I can’t complete the setup if i can’t finish the wifi configuration. Is this typical for these devices.

We are currently looking into this issue. I will post more once we have a clearer picture.

So thought I would add more details incase it helps.

I am having issues with a galaxy S21 Ultra, Windows 10 laptop, and Pixel Slate Chrome OS device connecting to the ap of the kit to setup the wifi. I finally tried on a raspberry pi running Ubuntu and have been able to manage some reliability with connecting to the kit. Not sure why those 3 devices wont work, but the Pi does.

Since finding out the Pi can connect reliably i have been trying to add it to my wifi and now that is not successful. It seems to randomly see a few networks that are week signals and not something that comes in strong. My wifi system is Google wifi. That is the older generation that has 2 ethernet ports in each puck. I am going to try to have it connect to a old netgear router when i get a chance to do some more testing.

The default firmware has a very low timeout for setting up the wifi, something like 30 seconds. I had some difficulty setting it up and had to be very nimble in setting it up. You can try flashing ESPHOME for AirGradient which contains the WiFi credentials as part of the flashing process. This would help to rule out whether you’re having issues with the original firmware or if it’s an issue with the hardware.

Well I think the problem now is that it just isn’t seeing the network. I just hooked up a older netgear router to see if it was a problem with using a mesh type system. The Netgear 6300v2 i attempted with now isn’t being seen either.

What is really strange is the networks that it does seem to be picking up are really far away. Like so far my phone doesn’t pick them up and then my pixel slate sees them for a short period of time and then they go away. With the default firmware you can also set them without selecting them and that doesn’t seem to work either.

I think the issue with the phone and the tablet are related to Chrome and how they handles sites that route their traffic through captiva as a proxy of sorts. Can’t say for windows, as it looked like it was going to start to work and then just died. Not sure why but atleast the raspberry pi has been very reliable connecting to the kit. It has been pretty much bullet prof at this point. I have also flashed the d1 mini now a few times as well. In doing that I did increase the timeout from 60 seconds to 120 seconds. Is there another timeout on the wifi configuration page?

By default the D1 only works on 2.4 GHz networks. Could it be that most of your networks are only communicating on 5Ghz?

Having said this, we are also looking into this and it appears different versions of D1s behave differently. We probably know a bit more in a few days and I will report back here.

I also just received a new DYI Pro Presoldered kit and have had issues both connecting to it to set up and connecting it to different wireless networks. I could not connect to the D1s using an iPhone 11, 2021 MacBook Pro, and Windows 10 desktop using a Mediatek MT7612U adapter. The only device I have been able to connect to the D1s is a Surface Pro 3. And even with the Surface 3 out of 5 times, I cannot connect to the D1s.

Like Craig_K I ended up increasing the timeout to 120 seconds which helped the Surface 3 connect, but none of the other devices I have tried to connect to the D1s.

The only network I have been able to connect to is from an Xfinity xFi Advanced Gateway (XB7).

  • 2.4 GHz
  • WPA2 Personal
  • 20 MHz Channel Width (Channel 6)

I have not been able to connect it to my Ubiquiti U6 Mesh or U6 LR access points with the same settings as the Xfinity gateway or various network settings. Including:

  • SSID broadcasting 2.4 GHz only
  • Client Device Isolation: Disabled
  • Proxy ARP: Disabled
  • BSS Transition: Disabled
  • UAPSD: Disabled
  • Fast Roaming: Disabled
  • PMF: Disabled

Also, my kit was missing the SHT31 sensor.

@fullduplex sorry for these issues. Please contact our support team through to rectify the issue.

We have looked into this issue over the last few days. So far we know the following:

We got two different D1 v4 mini versions from our suppliers. One supposed to be the original Wemos D1 mini and it also appears we got clones that funnily have the misspelling as “D1 mimi”.

We have tested all remaining D1s in our office and it appears that the clone “Mimi” is fully working and does not have any WiFi issues.

We found a number of the -supposed to be original D1s- with the WiFi issues described above and are currently contacting the supplier for comment and possible rectifiation.

Everybody who has this issue, please contact us through our website form so that we can rectify the situation for you.

@AirGradient Thank you for that detailed explanation and prompt response!

I just reached out using the contact form. Thank you very much for your help.

Further information for your debugging:
I’ve tried on several devices.
iPadOS - cannot connect
Android - after about 10 tries, managed connection, but couldn’t get AG device to save Wfi credentials
Windows laptop - connected first attempt, saved credentials.

then at the router:
ASUS rt-ac86u - shows connecting for 10 to 30 seconds, but no data
changed router:
GL-inet AR750S - connected & data sent to AirGradient. Success!

unfortunately, I disconnected to move the router & the AG hasn’t successfully connected back!

Just adding my data points…

Tried to connect to the AP of my pre-soldered kit from a W11 PC, a Macbook, and from my Pixel 6 phone. The AP SSID is shown, but none of the devices are able to connect and thus are unable access the web-based configuration. Then the DIY kit boots into offline mode since no successful connection was established.

I have a variety of IoT devices that are 2.4 only (e.g., ESP32) that are successfully connected.

Please send a message via our website and also everybody else who has this issue so that we can rectify the situation for you.

It looks like we got a limited number of D1’s with WiFi issues.

Yes, I submitted my issue via the contact form a little over a week ago, so you should have my info there.

Something i just noticed looking at this thread that the ones that seem to be identified as original here are not either. The silk screen on these boards are not the same as the official board in that post either. Simply put these boards that appear to be failing do not have any silkscreen on the top of the boards with the USB-c port unlike in that post. I don’t think these are official Lolin d1 mini’s.

I’ve received the replacement D1 & it immediately resolved the ability to connect to it for initial Wifi configuration. iPad connected instantly. Great.

However I’m having issues connecting to the configured wifi when re-powering the AG Pro. It is hit & miss whether it will join my network. Mostly not, or not for a long time.

I found 2 ways to successfully force reconnection:

  • Do anything to reset or change my wifi (eg enable/disable, reboot, change a wifi parameter)
  • Reset the D1 when it is connected via a USB cable to the PC. (An option that appears when readying to flash firmware).

The router is an ASUS RT-AC86U. I have typically 12-16 items (all various IoT devices) connected to the 2.4 wifi with no other device having issues. The AG Pro is the only explicit ESP device.
I have reflashed the firmware with both original firmware & the Home Assistant ESPHome configuration.

What next?

First time I hear about this issue and I think it is router related.

A bit of googling shows quite a few people having the same issues, e.g.

In my case that is not the solution as the mentioned parameter (“Protected Management Frames”) is disabled. I’ve tried several router parameters with several false initial successes.

Possibly a wifi channel 12 problem.
The connection is maybe most unstable when “Auto select channel including channel 12, 13” was selected. Just selecting “Auto” channel nearly always selected channel 2. “Auto select channel including channel 12, 13” nearly always selected channel 12.

I have hard set channel 11 for a trial.
The AG-Pro connects much faster. I found reference to ESP devices active scan channel 1-11 & passive scan channel 12-14. That explains the faster connection & is a reason not to use those channels for ESP devices

Then I found this blog article which has the same messages I get in the log, but I didn’t initially find meaning.

So avoid WiFi channel 12-13-14 when working with ESP devices! I’ll update if this doesn’t work.

Thank you for this detailed tests which I think can be helpful for others as well.
Please keep us updated.

I also use the ASUS RT-AC86U and have no issue connecting ESP devices and I have 5. This said I also keep my router’s firmware up to date and I reflashed it with Asuswrt-Merlin. When I looked at the wifi configuration for the 2.4Mhz there are only 11 channels selectable. The Protected Managment Frames option is set to ‘Capable’, not disabled. There is a third option: ‘Required’. It could be that the default Asuswrt does not set the same options, I am unsure.