Issues with new DYI Pro Presoldered kit

@AirGradient Thank you for that detailed explanation and prompt response!

I just reached out using the contact form. Thank you very much for your help.

Further information for your debugging:
I’ve tried on several devices.
iPadOS - cannot connect
Android - after about 10 tries, managed connection, but couldn’t get AG device to save Wfi credentials
Windows laptop - connected first attempt, saved credentials.

then at the router:
ASUS rt-ac86u - shows connecting for 10 to 30 seconds, but no data
changed router:
GL-inet AR750S - connected & data sent to AirGradient. Success!

unfortunately, I disconnected to move the router & the AG hasn’t successfully connected back!

Just adding my data points…

Tried to connect to the AP of my pre-soldered kit from a W11 PC, a Macbook, and from my Pixel 6 phone. The AP SSID is shown, but none of the devices are able to connect and thus are unable access the web-based configuration. Then the DIY kit boots into offline mode since no successful connection was established.

I have a variety of IoT devices that are 2.4 only (e.g., ESP32) that are successfully connected.

Please send a message via our website and also everybody else who has this issue so that we can rectify the situation for you.

It looks like we got a limited number of D1’s with WiFi issues.

Yes, I submitted my issue via the contact form a little over a week ago, so you should have my info there.

Something i just noticed looking at this thread that the ones that seem to be identified as original here are not either. The silk screen on these boards are not the same as the official board in that post either. Simply put these boards that appear to be failing do not have any silkscreen on the top of the boards with the USB-c port unlike in that post. I don’t think these are official Lolin d1 mini’s.

I’ve received the replacement D1 & it immediately resolved the ability to connect to it for initial Wifi configuration. iPad connected instantly. Great.

However I’m having issues connecting to the configured wifi when re-powering the AG Pro. It is hit & miss whether it will join my network. Mostly not, or not for a long time.

I found 2 ways to successfully force reconnection:

  • Do anything to reset or change my wifi (eg enable/disable, reboot, change a wifi parameter)
  • Reset the D1 when it is connected via a USB cable to the PC. (An option that appears when readying to flash firmware).

The router is an ASUS RT-AC86U. I have typically 12-16 items (all various IoT devices) connected to the 2.4 wifi with no other device having issues. The AG Pro is the only explicit ESP device.
I have reflashed the firmware with both original firmware & the Home Assistant ESPHome configuration.

What next?

First time I hear about this issue and I think it is router related.

A bit of googling shows quite a few people having the same issues, e.g.

In my case that is not the solution as the mentioned parameter (“Protected Management Frames”) is disabled. I’ve tried several router parameters with several false initial successes.

Possibly a wifi channel 12 problem.
The connection is maybe most unstable when “Auto select channel including channel 12, 13” was selected. Just selecting “Auto” channel nearly always selected channel 2. “Auto select channel including channel 12, 13” nearly always selected channel 12.

I have hard set channel 11 for a trial.
The AG-Pro connects much faster. I found reference to ESP devices active scan channel 1-11 & passive scan channel 12-14. That explains the faster connection & is a reason not to use those channels for ESP devices

Then I found this blog article which has the same messages I get in the log, but I didn’t initially find meaning.

So avoid WiFi channel 12-13-14 when working with ESP devices! I’ll update if this doesn’t work.

Thank you for this detailed tests which I think can be helpful for others as well.
Please keep us updated.

I also use the ASUS RT-AC86U and have no issue connecting ESP devices and I have 5. This said I also keep my router’s firmware up to date and I reflashed it with Asuswrt-Merlin. When I looked at the wifi configuration for the 2.4Mhz there are only 11 channels selectable. The Protected Managment Frames option is set to ‘Capable’, not disabled. There is a third option: ‘Required’. It could be that the default Asuswrt does not set the same options, I am unsure.

Ive also have some problems with this KIT.

After flashing the D1 Mini V4 and setting up wifi SSID and Password thru the 60 sek wifi config window, its online, but after unplugging it and connecting it to the Pro Presoldered board it doesnt connect to wifi. And the Oled - Top left does not turn on.

If i unplugg the D1 Mini from the board it connects to the Wifi again…

Not sure what to do next…

I also use ASUSwrt-Merlin frequently updated to latest firmware. In my region channels 12 & 13 are legal & therefore appear as options.
Using channel 11 & 6 resulted in longer periods of connection, but still occasional disconnections. Once it took 5 hours to reconnect by itself.
Setting to Auto has used channel 2 or 3 & has resulted in several days with no connection issue.
The display has frozen twice after ~ 3 days. Re-power & the AG-Pro re-connects very quickly.

My key learning so far is only use wifi channels in the ESP active scan range, ie channel 1-11.

image

I’ve tried “legacy” setting, all bandwidth options, “disable 11b” , & more all with no impact to the issue.

All 2.4G devices are IoT & connect on wifi “n” with one exception connecting via “g”

Home Assistant keeps reasonable history & I can be certain the issue is only with the ESP device.
Interference with Zigbee is a possibility. I have almost 20 active devices, mostly on zigbee channel 25 (nearest wifi channel 13) & several on another device zigbee channel 11 (far edge of wifi channel 1).

Just an FYI from an old guy stumbling through the forums… with 2.4GHz wifi, there are only 3 ‘pure’ channels - 1, 6 and 11

Any other channel simply interferes with these channels :slight_smile:

Try set your channel to one of the only (this is probably spoken about in the above link I have not clicked on!)

2 Likes

I have 2 units which arrived yesterday, one is fine but the other refuses to connect to wifi after I save the details to it.

It sits for about 60 seconds and then boots into offline mode, I can see the data on the screen but I can access it from the unit.

Any suggestions?

Please contact us on the support form. We will send you a replacement.

As you mention, 1,6 & 11 are recommended channels. So I am surprised the ASUS auto select has chosen channel 2 & 3.
When I turned auto off, I first tried channel 11, then 6 - both unsuccessfully. The I went back to Auto select.
So far , on channel 3, it is stable.

The replacement has just arrived but it doesn’t connect, like the originally shipped D1 the replacement does not connect to my Wi-fi, my other unit purchased and delivered at the same time works fine.

This is getting frustrating looks like it will be several more weeks before this unit will be working, is there anything else I can do to confirm what the problem is, are you still sending out defective D1’s? I thought the faulty ones had been identified and removed.

Sorry for that but we are now hand testing every single D1 Mini that we send out if it connects to the WiFi. So I have no idea why you still have this issue. Please contact us at https://www.airgradient.com/support/ and we can see how to help you best. Thanks

Hi Again, after playing with it for some time it may have connected to my network however after adding it to the dashboard no data is showing, I can see data on the units display.

When I added it there was no confirmation that it was added, it is greyed out on the hardware admin table and the last seen time it not updating even though I have rebooted it and it seems to connect.