Issues connecting Wemos D1 to macOS

I bought the PRO kit (unsoldered) and have soldered it up, but am currently stuck at the flashing stage. My OS is unable to detect the Wemos.

I’m using macOS Monterey 12.5.1, which I understand comes pre-installed with the CH340 drivers.

Running ls -l /dev/cu.* after plugging in the device returns only /dev/cu.Bluetooth-Incoming-Port.

Running ls -l /System/Library/DriverExtensions returns the following USB drivers:

A blue light blinks momentarily when I plug in the USB cable.

I tried using both a Ugreen USB-C to USB-C cable, as well as the USB-C to USB-A cable included in the PRO kit. Both didn’t work.

Anyone knows what the issue might be?

I also noticed that the Wemos PCB silkscreen says “D1 mimi v4.0.0” (note the typo). Is this a legit D1? Could this be the issue?


Can you try and flash it through the website instruction page directly (flashing via the browser). Does that work?

Flashing via the browser doesn’t work, as the only serial interface detected was /dev/cu.Bluetooth-Incoming-Port.

To add onto the initial post, I’m using an Intel Mac.

Here are the photos of the Wemos D1 I got with my PRO kit. It’s labelled “D1 mimi” (a typo) instead of “D1 mini”. The D1 I got also has 45 degree corners and the sides are rough. Was I sent a counterfeit / fake board?

The one on LOLIN’s Aliexpress store has a different silkscreen, rounded edges at the corners and are smooth on the sides (no rough “fingers” sticking out): Lolin D1 Mini V4.0.0 - Wemos Wifi Internet Of Things Board Based Esp8266 4mb Micropython Nodemcu Arduino Compatible - Integrated Circuits - AliExpress

^ Note the typo “mimi” and the 45 degree cut angle next to the antenna.

^ Rough edges with little fingers sticking out along the length.

On a different note, can the USB-C to USB-A cable included in the PRO kit be used to flash the D1?

We have contacted our supplier about this and will try to return our existing sock and ensure we get genuine ones.

Having said that, we have tested around 50 of them over the last few days and all seem to work fine. So there seems to be no systematic issue.

Can you try and flash with a different computer (eg a windowsj?

I haven’t received a pre-soldered kit but it would be a good idea to try a different cable, if you haven’t already. Make sure it says that it supports data. Some USB-C cables don’t have the data pins connected (which is really useful when charging my phone in an untrusted power port).

FWIW, when I ordered D1 mini V4 boards from the Lolin official AliExpress store (link), they came like this:

I just bought a Wemos D1 mini direct from the LOLIN Aliexpress store, and it worked straight out of the package! My Mac detected it right away and I could flash directly from the browser. No driver installation required.

Any chance for a replacement of the defective D1 that came with the kit?

Comparison photo for reference (LOLIN’s D1 on top, the Airgradient kit D1 at the bottom):

Everybody who has issues please contact our support via the form on our website.

Thanks! Just submitted a support request via that form.