Wemos D1 not appearing over serial when slotted onto board


I am hoping this is just a bad solder or something. I have flashed the firmware and can confirm it is working because I am getting logs out of the microcontroller when it is not slotted onto the board. As soon as I plug it into the board however the device won’t boot. No flash on startup, it doesn’t appear over serial, and it cannot be pinged on the network. I have put the D1 and the sensiron on a breadboard and am able to get readings from it. Troubleshooting so far:

  • confirmed SHT3x is not soldered upside down
  • confirmed the connections to the sensiron work
  • checked the PMS5003 solder to make sure the pads aren’t shorting
  • checked the oled solders / wiring to make sure it is correct
  • tried with / without the battery hat, with cable plugged in to both the micro usb on that board and the micro usb on the mainboard

PCB is v3.1 so I followed the <3.7 guide. Feeling a little defeated now. Photo attached. I can’t attach the other.

Extra photo I wasn’t allowed to attach:

With all sensors removed that you can, it still doesn’t power on when put into the board? OLED is going to have to stay, but without the SHT and the PMS?

You won’t get any serial output over the AirGradient board’s USB as it only provides power with this version, but you can keep the D1 plugged in USB to get power and have it slotted into the main board.

If it still fails even with everything removed that you can, it sounds like a short to me. I would double check the circled areas to make sure they aren’t bridging where they shouldn’t, but I haven’t been this deep on mine for awhile so not sure where the traces should touch the pads and where they should just fit between