TVOC sensor troubleshooting

My TVOC is consistently reporting TVOC 100 and NOX: 1. I believe it should fluctuate but i’m not too sure. I flashed again but same results.

At the bottom of this link you find a video with a way to these the sensor:

Thanks! i’m confused about this. Do I need to purchase more equipment? i installed the control center and plugged in my airgradient via usb but it doesnt read.

I also showed 100 / 1 all the time, my problem was that the contact was bad (the flux got on the legs), I just soldered the sensor to the board and now it works fine.

1 Like

No need to purchase something or install something. Just look at how the sensors are triggered/tested (in video ‘SGP41 Gas Sensor Evaluation Kit: Introduction’ VOC-test at 5:10 - 5:50 and NOx-test at 5:50 - 6:25) .
You just need two glasses and a gas-lighter.

got it. good news i know all sensors are working because the dashboard is reflecting real-time changes. the bad news is that the led screen doesn’t display when i have them plugged in. anyone encounter this issue?

edit: i think tvoc is working based on readings but temp and humidity is constantly 0

this is my reading . is it right to assume only the sht module isnt working?

{“wifi”:-62, “rco2”:479, “tvoc_index”:100, “nox_index”:1, “atmp”:0.00, “rhum”:0}


this is a snippet from my logs. constant tvoc and fluctuating co2

Do you actually have the TVOC sensor?

It was a separate purchase and we only inluded it in the kits by default since last week. It looks like this:


I ordered it, I soldered it directly on and still not working. I spent so much time debugging that Im calling it quits. Ordered a separate sht30 sensor and that didn’t work either. Only thing that works consistently is the CO2 sensor.

Hard to tell from this angle, but the first pin’s solder joint looks like it isn’t making contact. I would check all your solder joints. When my sensors were reporting constant or negative values, it turned out that I had to fix a couple solder points and reseat the power cable for the PM sensor.

1 Like

Can you please post a lot more photos so that we can check if we spot anything causing a short if something.

I uploaded my photo dump. I unsoldered the SHT30 and TVOC sensor since they weren’t working. Combinations of soldering the SHT30 and TVOC read 0 without shorts. When i tried soldering on my newly purchased SHT30 modules The LCD screen goes blank instead of reading 0. So I unsoldered them.

Are there any ways I can solder them in another way? i think the pads have been burned off at this point

Edit: were back in business after watching a lot of soldering tutorials.

Okay, this is where I am.

Only thing left is the tvoc sensor.

The back

And the front.


If the soldering for the contacts on the TVOC sensor seem solid, give it some time. The sensor’s output is based on an index where 100 is the baseline average over some period of time. Increases or decreases are relative. (To my understanding)

You can probably test by opening a bottle of rubbing alcohol nearby, if it goes up it should be working.

unfortunately still the same. i did the lighter test and the numbers don’t move. i would try and solder the tvoc directly on but the pins are in such a weird angle. anyone have a solution for that? or is there some part on the mcu that needs reflowing?

It’s possible you might need to reflow the MCU pins as well (top and bottom). Do you have flux? It will help. If flux doesn’t help with reflowing, I would get some solder wick, remove as much solder as you can and do these over with fresh solder and flux. Is your soldering iron hot enough? Are you using a small tip? What solder are you using? 63/37 will melt at a lower temp which will help too.

These are very small and close together contact points and I found them a little tricky.