Tools/Get Board Info - what is the correct info?

Stuck on
esptool.FatalError: Failed to connect to ESP8266: Timed out waiting for packet header
Latest attempt:
Upgraded Ubuntu to 22.04 - someone reported a bug in the linux kernel that would prevent the ESP8266 connection, and the latest (2022, April) Ubuntu had the new kernel.
Reinstalled latest arduino 1.8.18
Added the additional Board Manager link in Preferences
Restarted Aduino so it would find the Board
Gave myself access permission to /dev/ttyUSB0 which shows up properly on the Tools menu, and in Linux:
QinHeng Electronics CH340 serial converter

Selected the Lolin (Wemos) D1 Mini board (there are 3, all give same connect error)
I clicked Get Board Info from Tools and see:
BN: Unknown board
VID: 1A86
PID: 7523
SN: Upload any sketch to obtain it

Is this normal, and if not what should I try next?
Trying the flash on a Windows machine is not a real option for me
Before the upgrade of Ubuntu (with the supposed kernel fix), I got the same error.
The ESP8266 is brand new, nothing yet soldered. LED flashes as arduino tries the connection 12 times, so something in the chip is connected. I’m assuming that tells me the USB cable is good, right?

Blink terminates with “Hash of data verified. Leaving… Hard resetting via RTS pin…”

D3 - Ground connect

Hopefully this will help somebody else get started. tuned out to be my friend. It’s installed as part of the arduino install (Ubuntu) so able to use it immediately & know that results would be reproducible.
Initial prob: trying to get the basic Blink to work on the bare chip
The read buffers/headers were failing and different dependent on baud rate which is why I guess people play with that param.
I googled the error msgs I saw.
Although I had seen the D3 Gnd connection suggestion multiple times, I thought it would show up in this forum if it were a known problem with our chip. Don’t find it with the search tool
I connected D3 Gnd and Blick worked for the first time except it terminated with
Hash of data verified.
Hard resetting via RTS pin…
How is that fixed? Do I pull the D3 Gnd after the connection starts?
On to soldering.