Pre-soldered kit - temp and humidity not working


I’m getting my pro DIY pre-soldered kit up and running for the first time. The temperature and humidity seem to be reading default values. The PM 2.5 might be the same, I’ve never seen it deviate from 0.

The temp/humidity sensor is placed correctly in the kit according to the instructions. I don’t know what could be wrong. Any ideas?

Please post photos of your PCB.

Here they are

I cannot see a problem. What power supply do you use? Did you try a different one?

I’ve just tried a couple different USB power supplies of different types and it is the same behavior.

Is it possible my unit or the sensor is defective? Is there an RMA process where I could exchange the sensor for a working one?

I would double check the solder on the VIN pin on the SHT chip. Looks a bit sparse compared to others

I looked a bit more closely and I do see the solder on the VIN pin is a bit more rounded, like maybe it didn’t penetrate fully with the contact on the bottom.


I got my smallest-tipped soldering iron and heated up the blob and got it to flow a bit more so it looks more normal.


But it still reads 32 F and 0% humidity, so no change.

I send you an email to have a quick zoom call and discuss the next steps but it looks like you need some replacement parts.

@dom can you create a bit of smoke and check if the PM sensor goes abobe zero so that we can be sure that one works.

The replacement temperature sensor worked! Thanks

@AirGradient after leaving the unit on for a little while (an hour or several), the default value for temp and humidity come back. If I restart the unit, it reliably boots and shows the correct temp/humidity. But after a while it reverts to showing defaults again. Any ideas what could be the problem now?

Here’s an update after the above screenshots showing where I powercycled the unit. It started capturing temp data and then drops down to default values and stays there.

So just for my understanding, you have the same behavior for two different temperature sensors?

So just for my understanding, you have the same behavior for two different temperature sensors?

I wouldn’t say that. The first temperature sensor I received with my pre-soldered kit didn’t work under any circumstance. I reset the unit multiple times, tried different sensor ports, and it never showed anything other than default values.

The new sensor I received does work initially when I boot the unit. But after some time, maybe 20 minutes, or a few hours, it stops working and then displays default values again. I can reset the unit and see the correct values again for a short time.

Are you able to measure the voltage on the 3.3 I2C bus?

I’m not sure how to do that. If you can give me some very specific instructions, I can give it a try.