NaN being often reported for every value with ONE (version 9) and ESPHome


I have a DIY Pro that I have upgraded with a ONE mainboard (version 9).
I am using the ESPHome integration from MallocArray and everything was working fine since december.
I haven’t touched anything since that time, but since some weeks I have a lot of NaN (undefined value) for every value (temperature, CO2, etc.) quite often.
At the beginning, I was perhaps only getting this NaN once per day, and for a very short time.
Now it is all the time and sometimes for quite a long time.
See this picture, for instance for the CO2, where you can see that it is happening a lot during the day:

Do you think this is a hardware problem or a software problem ?
What can I do to isolate the issue ?

Thanks a lot in advance,

Start by pulling the power cable for 5-10 seconds and reconnect. That might be enough.

I tried of course to disconnect, reconnect.
I also tried to let it outside for one day and re-calibrate manually.
Nothing so far had any significant impact on the issue.

You are seeing NaN on the display of the device as well, or only gaps in the AirGradient Dashboard site?

There are regular updates to ESPHome, so you may try updating your ESPHome install and then doing an update to your device, just as a general housekeeping item.

Overall my ONE has been reliable in readings, but one of my earlier Pro boards has an issue after a month or so of uptime and I have to physically reset it, but other devices with similar setup don’t, so unable to pinpoint a software issue in that use case.

Maybe try and use a different power supply?

I see also NaN on the display.

Yes I would have done that but I am a bit reluctant as it was working before: I am afraid to introduce new issues in the system by updating which may make the debugging even harder.
I’ll try a new power supply as Achim suggested first.

So changing the power supply seems to improve things a bit:

But I still often have NaN appearing even if not for long (so you don’t see them on the graphic as it is only for a short time).

I am using an iPhone charger for power supply: could it be that it is not suitable ?
I will try to use something else to try.

Try a charger with at least 1.5A. Probably would be good to try a few different ones as it not only depends on the A but also on the general voltage stability.

I tried for the last 24 hours a charger 5.3V 2.0A and the result is not good:

But do you really think that the issue is with the charger ?
It was working fine for months before that…

If you have a good charger to recommend…

I’ve used some low end 1.0 A chargers with no issue, so I’m doubtful that all of your issues would be resolved with a different charger at this point.

If it were me, I would update ESPHome and go from there.

Another issue could be a more congested WiFi network that might drop certain requests to our server but that shouldn’t show “-” on the display

Hi. I have the same problem.

To solve it, disable the upload data to the dashboard working only in local with Home Assistant. The problem, at least in my case, fully disappeared

Ok so I tried updating ESPHome to the latest version and I don’t see any improvement:

What you cannot see on the graphic, is that I often see NaN on the display for a short period.

So what else can I try ?
I’ll try to disable the upload, but I have some doubt that it is related. I’ll try anyway.

Lo and behold, it works !
In the last 24 hours, I haven’t got a single NaN !
Thank you so much, I would never have thought about that.
But… what is happening here ? What is the explanation ?
How can the upload have an impact on the measured values ?