My unit came with SHT4x for the temperature sensor and the software does not seem to support it

I have just gotten my sensor and have put it together. The temp and humidity are both reading zero. The build instruction specifically state that either an SHT30 or and SHT40 may be provided. I got an SHT40, SHT4x actually according to the board. Anyway, it doesn’t read anything. I downloaded a library specifically for the SHT4X and ran an example code on it and was able to get both temperature and humidity readings. So the install is correct. I am no code wizard but I looked in the library files and all they hare is reference to the SHT30. In my vast ignorance I went ahead and tried replacing all instances of SHT30 with what is in the other library for the SHT4x. Well, that didn’t work. Anybody run into this? My “easiest” fix I suppose is to order a SHT3x. But just kind of wish they would have sent along the hardware that will work with the provided code. Maybe, likely I am missing something.

Happy to help but let me know if you have the Pro or the basic kit and are you planning to use the AirGradient software or something else like ESPhome?

I have the basic kit and I am using the AirGradient software.

Somehow the Arduino has not pulled the update yet from our github. I will look into this. In the meantime you can flash the software through our web flasher:

Above one supports the SHT40. I just tested it.

That did it! thank you. It was not working before, which is why I went down the Arduino rabbet hole. As it turns out my issue was the board was not connecting to my computer. After messing with it for a while it finally did. I don’t know what I did to finally get it to connect… but now I am working on my second board. And it is not connecting either. I have tried all of the crazy little things I did on the first one to finally get it to take with no luck. Not sure what else to try at this point.

Please post some photos. If the board does not connect it could indicate something put together wrongly on the board.

I did just think of this, that it is sort of identified when I go to “board information” then I get this. image
Which while “unknown” is the same information from the other board that does connect. So maybe it is being seen? but still not working. anyway, here are pictures.


and then if this means anything to you other than not connecting I will provide it as well.

Try and unplug the PM cable and take out the SHT sensor when flashing. These might draw too much power during the flashing process.

Unfortunately that did not work either. I have tried different cables as well, but still no good. :\

For what it is worth, I tried this on another computer. set it all up tried to upload the blink program for this board and still won’t connect.

Please send photos of the new unit. Both sides.

Did the pictures above come through? That is the new unit. the one that is not connecting. I have trouble shot some more trying things specific to the Wemos mini D1 module not connecting. nothing seems to be working. My next trick is to buy a new wemos, somehow figure out how to unsolder what is in there, maybe flash the software on BEFORE soldering it in place and then put in a new board. As far as I can tell it is a bum board. Unless you have any better ideas?

My new boards came in. I sawed this one off of my board and soldered on a new one and it works great now!

I’ve made a PR into ESPHome-AirGradient to set the default temperature sensor to SHT4x, along with comments suggesting users check their version on first setup.

1 Like