Issues with temp/humidity sensor on AirGradient ONE v9 board and v3 of firmware

So I upgraded both my AirGradient ONE’s to the new v9 boards a few months ago. I pulled all parts from old boards to the new and everything worked great. Today I updated both the boards to the latest firmware 3.0.0 and now one of units shows -428.8 as temp and -% for humidity. Im 100% sure the SHT is fine because it worked great before the new firmware. I also tried another re-flash with a data wipe and that did nothing. The only thing I can think it may be is the temp sensor is a SHT3X (31 I think) not a SHT40.

Any help is appreciated!

The current firmware only supports the SHT40. I did not think about the case where people upgraded the board and continued to use the old SHT30.

I think we will be able to support the old sensor too and will ask our developer to add support.

Thank for the info Achim! Could I just get a SHT40 off Amazon/Aliexpress and use one of those or do I need to buy one from you guys?

A 3rd party module could work but we had issues in the past with the pull up resistors on these modules. Since we already have pull ups from the oled display it might exceed the rating and work unstable.

Please contact our support team via our website. Depending on your shipping location we might find a cost effective way to send you one of our modules.