IDE cant find header files

Hi, I am having a problem that I have seen around happens to several people. The thing is that when trying to compile or upload any program to the D1 mini, the Arduino IDE doesnt find some header files. I have seen in posts such as this: esp8266 using arduino IDE - Everything ESP8266 that the solution is to paste the header into another location as the IDE looks for them there. The problem for me now is that with the files inside the correct folder, following the path of the error, I can see the file it says is missing yet it is reported as missing. Does anyone have any insights on this? I am using the versions recommended inside the program C02_PM_SHT_OLED_WIFI from the AirGradient libray example

What exact version of the Arduino IDE are you using?

Hi, after several hours trying to fix it I tried running it on another device and it worked flawlessly. Turns out that it was an issue of using the Arduino IDE from de MS Store instead of the official download. :slight_smile: :gun:

Thanks for the fast reply