Getting 400 "Bad Request" despite DIY serial number being registered on dashboard

Hello, I’m trying to troubleshoot why this may be happening. I’m seeing this in the logs


I can confirm that is a lowercase version of the wemos chip ID (it says "init " on the screen after boot, and that I have registered that chip Id (lower case) on the platform dashboard (internal ID on the dashboard is ID 2092 if it helps the AirGradient team diagnose, happy to provide the chip ID in a DM). I am using the stock “CO2_PM_SHT_OLED_WIFI” example, and have connected wifi.

Thank you!

Also is there any documentation about the format that the dashboard API expects? I ask because I also tried out this version of the software Fix to PMS_Init and add new example ADVANCED_WITH_OTA by init99 · Pull Request #7 · airgradienthq/arduino · GitHub and noticed that it passed the numbers as strings in the JSON rather than numbers. Both versions fail, but I’m not sure what the API is expecting.

@abosworth Please send me a support ticket with your sensor chip ID and your username email address and I will have a look.


1 Like

I haven’t seen a document, but in my testing with the API with ESPHome I needed to convert everything to a string before it worked as expected.

1 Like

Yes good point. We send all data as string to the backend.