Firmware 3.1.4 on Home Assistant

Greetings,
Updated my Home Assistant then updated my Air Gradients. I’m so excited! Thank you all for the hard work! This is amazing. I’ve got the features that I personally desired and I really appreciate it.

One thing that I found odd. I updated the firmware with the USB cable and the web installer:
https://www.airgradient.com/documentation/firmwares/

It said successful… I have all the new features… but Home Assistant still thinks the firmware is 3.1.1 and not 3.1.4 :thinking:
Is anyone else seeing this or did I do something wrong?

Device Info
I-9PSL
by AirGradient
Firmware: 3.1.1
Serial number:

:man_shrugging:
Thanks!

1 Like

I understand that the configuration is only read from the device every 10? minutes or so. So maybe it needs some time to update.
If not please let me know and I will check with the developers.

Greetings,
Even after over a day - it’s still saying 3.1.1. But I clearly have the new features… :man_shrugging:
Thanks!

Some of the new features could have come from the Home Assistant Update not the firmware. When you boot the monitor, it should say the firmware version on the screen. What do you see there?

So this is interesting…
I plug in and it says

  • Firmware 3.1.4
  • press now for led test
  • sensor initializing
  • press now for offline mode…
  • connect to wifi
    -coonnecting to server
  • server connection successful
  • success
  • firmware update fail will retry

Um… I missed that before…

So let’s try this again…
https://www.airgradient.com/documentation/firmwares/
“flash now” on version 3.1.4
Install Airgradient one / open air version 3.1.4 (30JUN24)
click next (I did not erase device as I didn’t want to have to rejoin it to HA - maybe this is my problem?)
Do you want to install… and I click INSTALL
It prepares, installs, wrapping up, device reboots, installation complete :tada: , and I’ve got the same boot sequence as listed above…

So again, I’m confused. It says it’s on 3.1.4, but it also says “Firmware Update fail, will retry”.

Thoughts?

Great! I posted the same observation in another section of the Forum. The same issue happened to me, I had to install version 3.1.1 for my HA to fully recognize it. But then, after a few hours, I checked and the firmware had been updated to 3.1.4 and everything works perfectly!! Thanks to OTA feature.

@stack I found your note here last night because (aside from the Home Assistant integration… haven’t done that yet on my side) I was experiencing the exact same thing (including the “firmware update fail will retry” message. Hoped to find the magic answer when I got to the bottom of the thread here but it looks like you are still fighting with it. I kept digging and managed to get mine resolved.

tl;dr - check, check, and then check again that you don’t have anything in your network setup that will prevent the Air Gradient box from getting out to the internet.

I popped open the dashboard yesterday and noticed that I had not received any updates since July 9. Rebooting didn’t help. Dug around on the forums here and found that there were WiFi issues with some recent firmware releases when the unit lost power. Everything else on my network was working fine. I live close to Houston and that was hurricane day. We did lose power a couple of times. I mentally shifted full-on to “I’ve got the wifi firmware bug” (which turned out to be inaccurate).

I was on 3.1.1 as of yesterday. I attached the Air Gradient One to my PC and flashed the firmware from 3.1.1 to 3.14 just like you. Also just like you, I was getting the exact same message progression as you listed in your last thread, including the “firmware update fail will retry” message.

I could see from my WiFi management tool that the unit was successfully connecting to my WiFi network. Still kept getting the same “firmware update fail” message. I flashed back and forth from 3.1.1 to 3.14 to no avail. Zero activity on the dashboard. I bit the bullet and tried wiping my device from the dashboard (I only had about a month of history… didn’t want to lose it, but I was at a loss for what else to try. No change. $%&#@$%&

FINALLLLLY (should have been the first thing I did) I looked in my firewall logs… I was getting blocked traffic there from a “default state violation” and had my “oh yeah…” light bulb go on. I have a very intentionally segmented network with VLANs… I usually group my IOT devices by vendor and stuff them into their own VLAN to limit what other devices they can chat with.

On Monday I realized that I had never moved the Air Gradient box into its new VLAN home, so I wasn’t just watching the storm blow through but I was tinkering with my firewall. I had set up its new VLAN, moved it over, and never bothered to check that it was still working afterwards. I had forgotten to allow internet access out of that stupid vlan!

In hindsight, I sort of think now that the “firmware update fail, will retry” message was not referring to a failed attempt on my part to go from 3.1.1 to 3.1.4 but instead it meant that it was failing to update the dashboard with its current version number and check for any new updates over wifi (because it couldn’t reach the internet)…

Good luck to you!

Thanks for reporting this. We will check that error message on our side and how it is implemented in our firmware. Maybe the text can be improved.

1 Like

Thanks for the feedback everyone. I have three AGOne’s.

All three now boot and say they are on the right firmware.
All three now give the “firmware update fail, will retry” message.
All three report into Home Assistant and as far as I can tell are working great. (Eg: no issues with wifi/firewall/ect)
Two of the three report the correct firmware in Home Assistant - one does not. :man_shrugging:

Thanks!

1 Like

Can you please use a computer in the same local network that your monitors are connected to and put this in the browser:

http://airgradient_ecda3b1fffaf.local/measures/current

Replace “ecda3b1fffaf” with the serial number of your monitor.

Then you should get a response that includes the firmware version. Please check for all three and let us know what version you get.

Greetings,
1 is 3.1.1 and the other two are 3.1.4.
So I tried a reflash.
Now HA reports it as 3.1.4. :man_shrugging:
Still have the update failed message. Still appears to be working as it should.
Thanks for looking into this!