Firmware 3.1.1 Released

@MallocArray @Alan_Ng We currently investigate some models not updating. The ones that did not update on your end were Open Air or ONEs?

ONE for me, indoor model

Hi Joshua, the indoor model should automatically update to 3.1.3. Can you PM me the serial number and we will have a look.

I got it. I had connected this device to the HomeAssistant Integration and by default it switched my device to Local control, which prevented it from getting the firmware update from the OTA servers.

As soon as I switched it to Cloud control in HomeAssistant, it showed the new firmware and began downloading.

So a few thoughts:

  1. The AirGradient Integration for HomeAssistant should probably default to Cloud control so by simply adding it to HA, you aren’t fundamentally changing the operation of the device, and let the user choose to configure it from Local control. (There aren’t any local configurable options in the HA integration at this time anyway, so not necessary at all at this time)
  2. As an end user, I should have some control over when firmware updates occur, and possibly opt-in for automatic updates. Surprising me with a new version that could change how it behaves or causes a reboot when I’m not expecting it is not a great experience
  3. AirGradient should probably have a phase out mechanism in place, similar to cell phone OS updates. Start with only 1-5% getting the firmware update, wait a day or two, then 25% get the update, wait a day or two, then 75% or all get the update. That way if there is a flaw in the new update, you aren’t forcing all users to get it all at the same time, and not hitting the OTA servers all at once.

@Achim_AirGradient @MallocArray

I have 3 units of The AirGradient ONE (Model I-9PSL)

30 May Flash Unit S/N xxxe460 FW from v3.0.9 to v3.1.1
30 May keep Unit S/N xxx3614 current FW v3.0.9 for compare with v3.1.1

05 Jun Flash Unit S/N xxxe444 FW from V3.0.9 to V3.1.1 and offline due to case is broken

06 Jun Flash Unit S/N xxx3614 FW from V3.0.9 to V3.1.1 due to observed some issues that compared with v3.1.1. Achim suggested to flash the Unit FM V3.0.9 to v3.1.1 to resolve the issue of CO2 LED turn on issues.
Observed both units of V3.1.1 all CO2 and PM2 levels are almost the same at the same location. The CO2 LED turn on issues are resolved.

07 Jun Found Home Assistant detected the above 2 units then I added to HA

12 Jun Restore Unit S/N xxxe444 which its FW is v3.1.1 when power on the unit OTA updated function and updated the FW from V3.0.9 to V3.1.3 automatically.
This unit is not added to HA yet.

12 Jun Try to power cycles and wait for OTA updates on the others Unit xxxxe460 and xxxx3614 do not found OTA function. Finally flash the FW to V3.1.3 from Web flash page.

Also found the 2 units is not connected to Wifi Server even the off line setting is default OFF
I have to Set Off line to ON then OFF, the units start Wifi AP to connect Home wifi and connected to AirGradient Server then the unit FM version can be displayed on Dashboard.

Finally, all 3 units are added to HA on 12 JUN

Is the OTA not working due to 2 units are added to HA ?

In HA, go to Settings>Devices>AirGradient and click where it says “1 Device” or in your case, “2 Devices”
From the Device Info page, change the “Configuration source” from Local to Cloud. You may see an error when selecting this, but it does appear to have changed it for me.

After less than 2 minutes, my device found the firmware update and downloaded and installed it.


Thank for you updates and comments. I am manual updated 2 units to v3.1.3 already with I do not change this configuration from Loca to Cloud the future OTA is still not working, am I right?
One more question if I do not add this 2 units to HA than the OTA will be working under AirGradient Dashboard, am I right?


Yes I pretty much agree.

We do already have a phased roll out in place and used that for many years with our old closed source firmware.

We are also looking to integrate the firmware update directly into HA. So HA would inform you about a new version and then you can click a button and then the update will take place.

My ONE I-9PSL seemed to be updated via OTA this morning (UTC-7) to 3.1.3 because after that it was not reporting to the airgradient dashboard almost all day. I then power cycled the device and confirmed that it was running 3.1.3, it then sends data to the dashboard. However, I still get an “add to dashboard” message on the oled screen. Just to confirm, boot count is a count of the measurement cycles and not the booting of device itself right?

Please contact our support with the serial number of the monitor. We will then have a look.

First check the “Show monitor information” on dashboard if it does not shown the FW v3.1.3 then it may be in offline mode.

My 2 units are not update to dashboard after manual refresh FW by Web page Refresh (monitor is erased first then flash).

No Sensor wifi AP prompted for setup. I checked the offline mode setting is default OFF when booting up process.

I have to Set Offline mode to ON then OFF then reboot, the units started Sensor Wifi AP prompted for Setup, after that sensor is connect to my home wifi successful.

All data is updating to dashboard and checked the “Shown monitor information” the FW V3.1.3 is shown on the page now!

I am not sure this is a software bug or not!

1 Like

I’ve submitted a zendesk request per Achim. After the OTA update and before the manual power cycle, the device was still connected to the WiFi but not communicating with the dashboard. However, I was not able to ping the device nor perform any GET requests on the endpoints on the local API (arduino/docs/ at master · airgradienthq/arduino · GitHub). No errors on the OLED screen either. Very odd. After manual power cycle, version 3.1.3 was displayed on the monitors screen and the device was able to connect to the AirGradient dashboard. I can now the see firmware 3.1.3 on the dashboard under "Show monitor information. I verified that offline mode is set to false via a GET Request. Everything appears to be working fine except I get *“add to dashboard” message on the monitor’s screen. Device was initially installed with 3.0.8 then I updated to 3.1.1 without erasing, with no problems until now with 3.1.3 fw version. Hopefully that is not the cause of the weird issues now.

I looked at it and answered the ticket.

1 Like