Failed to write to target Ram (result was 0107)

Hello, having an issue with my wimos D1 Mini where when i try to flash the blink package as per the instructions it errors and i get the following errors

Arduino: 1.8.19 (Windows 10), Board: “LOLIN(WEMOS) D1 R2 & mini, 80 MHz, Flash, Disabled (new aborts on oom), Disabled, All SSL ciphers (most compatible), 32KB cache + 32KB IRAM (balanced), Use pgm_read macros for IRAM/PROGMEM, 4MB (FS:2MB OTA:~1019KB), v2 Lower Memory, Disabled, None, Only Sketch, 921600”

Executable segment sizes:

ICACHE : 32768 - flash instruction cache

IROM : 231724 - code in flash (default or ICACHE_FLASH_ATTR)

IRAM : 26793 / 32768 - code in IRAM (IRAM_ATTR, ISRs…)

DATA : 1496 ) - initialized variables (global, static) in RAM/HEAP

RODATA : 876 ) / 81920 - constants (global, static) in RAM/HEAP

BSS : 25608 ) - zeroed variables (global, static) in RAM/HEAP

Sketch uses 260889 bytes (24%) of program storage space. Maximum is 1044464 bytes.

Global variables use 27980 bytes (34%) of dynamic memory, leaving 53940 bytes for local variables. Maximum is 81920 bytes. v3.0

Serial port COM3


Chip is ESP8266EX

Features: WiFi

Crystal is 26MHz

MAC: a8:48:fa:dd:55:49

Uploading stub…

Traceback (most recent call last):

File “C:\Users\dasaint\AppData\Local\Arduino15\packages\esp8266\hardware\esp8266\3.0.2/tools/”, line 66, in


File “C:/Users/dasaint/AppData/Local/Arduino15/packages/esp8266/hardware/esp8266/3.0.2/tools/esptool\”, line 3575, in main

esp = esp.run_stub()

File “C:/Users/dasaint/AppData/Local/Arduino15/packages/esp8266/hardware/esp8266/3.0.2/tools/esptool\”, line 722, in run_stub

self.mem_block(stub[field][from_offs:to_offs], seq)

File “C:/Users/dasaint/AppData/Local/Arduino15/packages/esp8266/hardware/esp8266/3.0.2/tools/esptool\”, line 611, in mem_block


File “C:/Users/dasaint/AppData/Local/Arduino15/packages/esp8266/hardware/esp8266/3.0.2/tools/esptool\”, line 423, in check_command

raise FatalError.WithResult('Failed to %s' % op_description, status_bytes)

esptool.FatalError: Failed to write to target RAM (result was 0107)

esptool.FatalError: Failed to write to target RAM (result was 0107)

Have you tried a different usb cable or a different usb port?

5th cable in now it works… man i had a lot of bad cables!!!

Thanks for the response @N_Ko

1 Like