DIY basic kit - SHT init failed

I’ve soldered DIY basic kit v4 by following instructions: The AirGradient DIY Air Quality Sensor (Basic Version PCB Version 4.0+)

Although I haven’t flashed prior to connecting all the pieces and done it at the end.

Once flashed via Webbrowser - got from logs: “SHT init failed”.

Then Installed Arduino IDE, tried flashing there - same error. Removed SHT sensor and commented the code - then got “SenseAirS8 init failed”.

After that decided unsolder D1 mini flash it and solder back, but introduced some additional mess.

Question - it seems I’ve getting error due to board initialization - does it mean I connected something wrong? What is the way to debug it?

First soldering experience - thought it’s going well until tried to flash and switch it on.

Photos attached (thanks Achim):

Can you please try again to post photos?

@Achim_AirGradient updated the post, thanks.

Not sure if it’s relevant, but prior to desoldering the D1 Mini, did the PM sensor and OLED display work? And did it connect to wifi?

I also had to learn the hard way not to solder things immediately to the board, because the D1 Mini v4 that I bought (not from the AG store) had defective wifi. So now, prior to soldering, I plug everything into a breadboard to test things out.

If you have some dupont cables (male to female), you can remove the OLED and connect the SHT/S8 using those?

Nothing was working and in logs I only got the message “SHT init failed”. When I commented that got “S8 failed”. Since it’s happening on boardInit() stage link I thought that something may be wrong completely -

I’ll still try to debug further - just was curious whether someone had a similar experience and what is the usual way of debugging since don’t have much experience with hardware.

But have picocom connection and Arduino IDE set up - will do try/error one. I wonder whether there is a separate example to init only D1 mini to make sure MCU is working as expected

Could you paste here all the logs you get after powering on the monitor? It might give some indication of the issue.

What is the way to get logs on boot?

I tried getting logs via picocom and “Flash firmware” → “Logs & Console”, but I only see “SHT init failed”. When I disconnect - all connections interrupting. - Share Text & Images the Easy Way

I tried manually pressing RST button on D1 mini, but it’s some unreadable binary printed - - Share Text & Images the Easy Way.

I may go with Arduino prints, but I believe there should be a better way. Not sure whether breakpoints are available there.

I had issue with the sht myself, but I had the init failed only with the sensor not properly making contact.
On side note for me the latest library won’t work with the sht3x, I had to downgrade to the previous one, otherwise the output of the sensor would be something like 0 -255

I am already testing the updated firmware that supports SHT30 (and SHT40). I hope we can publish sometime this week.

It is true that the SHT needs good contact with the board. So also worth checking the soldering.

I guess in my case it’s not only about SHT4x since when I disabled the code of initializing it - it started to print failures to initialized S8 sensor: “SenseAirS8 init failed”.

I may try downgrading the firmware though. @Mr_Cups what firmware version have you used?

AirGradient Air Quality Sensor 2.4.15