Added three I-9PSL monitors to Home Assistant - All LEDs and OLED stay in night mode now.

Added three I-9PSL monitors to Home Assistant - All LEDs and OLED stay in night mode now… OLED stays off all the time, even after setting both to 100% all the time and disabling turning off between 2am and 3am.

Firmware version of all three is 3.1.1.

Please check the brightness settings under Edit Location. There are also settings on Place level that can be overridden there.

Secondly ensure you can receive OTA update to 3.1.3. , ie don’t block the internet connection.

Hey Achim, Thank you for the reply.

Sorry, I made an error. The firmware version on all three is 3.1.3. (apologize!).

The monitor brightness LED/OLED is set 100% for both day/night on all three:

Also, I set the OLED/LED settings the same (all on 100%) on “Place” as well… no change so far.

Check under Place Administration, Led & Display the duration of the Day & Night time.

One more thing. You need to tell Home Assistant in the configuration to accept the cloud configuration.
It might be set to local configuration.

1 Like

You’re right… when I try to change it in Home Assistant it responds:

Failed to call service select/select_option. (‘Unexpected response from AirGradient’, {‘Content-Type’: ‘text/plain’, ‘response’: ‘Monitor set to accept only configuration from the cloud. Use property configurationControl to change.’})

But, it seems to have done it… it shows cloud for all four of my monitors (one outdoor, three indoor).

Yes there is an error message but as far as I know it will still work then and accept configuration from the airgradient server.

1 Like

LED/OLED are back now. I’ll try setting them to enabling the night setting again later … thank you for your help!

May I suggest to have a BH1750 Ambient Light Sensor installed on next hardware version of the AG in-door sensor monitor that it is more easy and flexible to control the LEDs and OLED ON/OFF by software under different ambient light level ?